Thumbnail carousel slider <= 1.0 - Cross-Site Request Forgery to Mass Slider Deletion

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-5821
CVSS 4.3 (Medium)
Publicly Published October 26, 2023
Last Updated January 22, 2024
Researcher Ala Arfaoui


The Thumbnail carousel slider plugin for WordPress is vulnerable to Cross-Site Request Forgery in version 1.0. This is due to missing nonce validation on the deleteselected function. This makes it possible for unauthenticated attackers to delete sliders in bulk via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Thumbnail carousel slider

Software Type Plugin
Software Slug wp-responsive-thumbnail-slider (view on
Patched? Yes
Remediation Update to version 1.0.1, or a newer patched version
Affected Version
  • 1.0 - 1.0
Patched Version
  • 1.0.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.