WP Shamsi <= 4.1.0 - Missing Authorization to Arbitrary Plugin Deactivation

Missing Authorization
CVE CVE-2022-4555
CVSS 6.5 (Medium)
Publicly Published November 28, 2022
Last Updated December 16, 2022
Researcher Chloe Chamberland - Wordfence


The WP Shamsi plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the deactivate() function hooked via init() in versions up to, and including, 4.1.0. This makes it possible for unauthenticated attackers to deactivate arbitrary plugins on the site. This can be used to deactivate security plugins that aids in exploiting other vulnerabilities.



Vulnerability Details for WP Shamsi – افزونه تاریخ شمسی و فارسی ساز وردپرس

Software Type Plugin
Software Slug wp-shamsi (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.1.1, or a newer patched version
Affected Version
  • <= 4.1.0
Patched Version
  • 4.1.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.