Shield Security <= 17.0.17 - Missing Authorization

Missing Authorization
CVE CVE-2023-0993
CVSS 4.3 (Medium)
Publicly Published April 25, 2023
Last Updated June 22, 2023
Researcher Ramuel Gall - Wordfence


The Shield Security plugin for WordPress is vulnerable to Missing Authorization on the 'theme-plugin-file' AJAX action in versions up to, and including, 17.0.17. This allows authenticated attackers to add arbitrary audit log entries indicating that a theme or plugin has been edited, and is also a vector for Cross-Site Scripting via CVE-2023-0992.



1 affected software package

Software Type Plugin
Software Slug wp-simple-firewall (view on
Patched? Yes
Remediation Update to version 17.0.18, or a newer patched version
Affected Version
  • < 17.0.18
Patched Version
  • 17.0.18

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.