WP SMS <= 6.5 - Cross-Site Request Forgery to Subscriber Deletion

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-6980
CVSS 4.3 (Medium)
Publicly Published January 2, 2024
Last Updated January 22, 2024
Researcher Krzysztof Zając - CERT PL


The WP SMS – Messaging & SMS Notification for WordPress, WooCommerce, GravityForms, etc plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 6.5. This is due to missing or incorrect nonce validation on the 'delete' action of the wp-sms-subscribers page. This makes it possible for unauthenticated attackers to delete subscribers via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for WP SMS – Ultimate SMS & MMS Notifications, 2FA, OTP, and Integrations with WooCommerce, GravityForms, and More

Software Type Plugin
Software Slug wp-sms (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.5.1, or a newer patched version
Affected Version
  • <= 6.5
Patched Version
  • 6.5.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.