Smush – Lazy Load Images, Optimize & Compress Images <= 3.9.8 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1009
CVSS 4.4 (Medium)
Publicly Published May 3, 2022
Last Updated December 5, 2022
Researcher Taurus Omar


The Smush – Lazy Load Images, Optimize & Compress Images plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'name' and 'description' parameters in versions up to, and including, 3.9.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This requires an attacker to trick an administrator into uploading a malicious configuration file in order to be successful.



Vulnerability Details for Smush Image Optimization – Optimize Images | Compress & Lazy Load Images | Convert WebP | Image CDN

Software Type Plugin
Software Slug wp-smushit (view on
Patched? Yes
Remediation Update to version 3.9.9, or a newer patched version
Affected Version
  • <= 3.9.8
Patched Version
  • 3.9.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.