WP Spell Check <= 9.17 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-22143
CVSS 4.3 (Medium)
Publicly Published January 12, 2024
Last Updated January 22, 2024
Researcher Mika


The WP Spell Check plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 9.17. This is due to missing or incorrect nonce validation on the wpscx_admin_empty_render() function. This makes it possible for unauthenticated attackers to update an API key via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for WP Spell Check

Software Type Plugin
Software Slug wp-spell-check (view on wordpress.org)
Patched? Yes
Remediation Update to version 9.18, or a newer patched version
Affected Version
  • <= 9.17
Patched Version
  • 9.18

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.