WP-Stateless – Google Cloud Storage <= 3.4.0 - Missing Authorization to Limited Arbitrary Options Update

Missing Authorization
CVE CVE-2024-1385
CVSS 7.1 (High)
Publicly Published April 5, 2024
Last Updated April 6, 2024
Researcher Krzysztof Zając - CERT PL


The WP-Stateless – Google Cloud Storage plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the dismiss_notices() function in all versions up to, and including, 3.4.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary option values to the current time, which may completely take a site offline.



Vulnerability Details for WP-Stateless – Google Cloud Storage

Software Type Plugin
Software Slug wp-stateless (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.1, or a newer patched version
Affected Version
  • <= 3.4.0
Patched Version
  • 3.4.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.