WP-TopBar <= 4.02 - Cross-Site Request Forgery to Stored Cross-Site Scripting

Cross-Site Request Forgery (CSRF)
CVSS 6.1 (Medium)
Publicly Published September 15, 2012
Last Updated December 5, 2022
Researcher Blake Entrekin


The WP-TopBar plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.02. This is due to missing or incorrect nonce validation in the admin pages. This makes it possible for unauthenticated attackers to gain otherwise restricted access and perform subsequent Stored Cross-Site Scripting attacks via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for WP-TopBar

Software Type Plugin
Software Slug wp-topbar (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.03, or a newer patched version
Affected Version
  • <= 4.02
Patched Version
  • 4.03

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.