WP Travel Engine <= 5.8.0 - Unauthenticated Price Manipulation

External Control of Assumed-Immutable Web Parameter
CVE CVE-2024-32798
CVSS 5.3 (Medium)
Publicly Published April 22, 2024
Last Updated April 29, 2024
Researcher Ananda Dhakal


The WP Travel Engine – Best Travel Booking WordPress Plugin plugin for WordPress is vulnerable to price manipulation in all versions up to, and including, 5.8.0. This is due to the plugin not properly validating a price. This makes it possible for unauthenticated attackers to manipulate the price of bookings.



Vulnerability Details for WP Travel Engine – Tour Booking Plugin – Tour Operator Software

Software Type Plugin
Software Slug wp-travel-engine (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.8.1, or a newer patched version
Affected Version
  • <= 5.8.0
Patched Version
  • 5.8.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.