Trending/Popular Post Slider and Widget <= 1.5.7 - Cross-Site Request Forgery via wtpsw_post_view_count

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-46846
CVSS 4.3 (Medium)
Publicly Published March 30, 2023
Last Updated April 3, 2023
Researcher Cat


The Trending/Popular Post Slider and Widget plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce verification on the wtpsw_post_view_count() function in versions up to, and including, 1.5.7. This makes it possible for unauthenticated attackers to increment the post view count via a forged request, granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug wp-trending-post-slider-and-widget (view on
Patched? Yes
Remediation Update to version 1.5.8, or a newer patched version
Affected Version
  • <= 1.5.7
Patched Version
  • 1.5.8

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.