Wp Ultimate Review <= 2.0.3 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-28987
CVSS 4.3 (Medium)
Publicly Published March 29, 2023
Last Updated January 22, 2024
Researcher Mika


The Wp Ultimate Review plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0.3. This is due to missing nonce validation on several functions like wur_settings_view(). This makes it possible for unauthenticated attackers to perform unauthorized actions like modifying the plugin's settings, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for WP Ultimate Review

Software Type Plugin
Software Slug wp-ultimate-review (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.0, or a newer patched version
Affected Version
  • <= 2.0.3
Patched Version
  • 2.1.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.