ProfilePress <= 4.13.1 - Limited Privilege Escalation via 'acceptable_defined_roles'

Improper Input Validation
CVE CVE-2023-41954
CVSS 7.3 (High)
Publicly Published September 9, 2023
Last Updated September 14, 2023
Researcher Revan Arifio


The ProfilePress plugin for WordPress is vulnerable to limited privilege escalation in versions up to, and including, 4.13.1 via the 'acceptable_defined_roles' function due to incomplete validation on a user controlled key. This can allow unauthenticated attackers to elevate their privileges to a non-administrator role during user-registration.



1 affected software package

Software Type Plugin
Software Slug wp-user-avatar (view on
Patched? Yes
Remediation Update to version 4.13.2, or a newer patched version
Affected Version
  • < 4.13.2
Patched Version
  • 4.13.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.