WP User Frontend <= 3.6.8 - Missing Authorization via AJAX actions

4.3
Missing Authorization
CVE CVE-2023-45002
CVSS 4.3 (Medium)
Publicly Published October 3, 2023
Last Updated January 22, 2024
Researcher Abdi Pranata

Description

The WP User Frontend plugin for WordPress is vulnerable to unauthorized functionality use due to a missing capability check on several functions corresponding to AJAX actions in versions up to, and including, 3.6.8. This makes it possible for authenticated attackers, with subscriber-level access and above, to install some plugins, delete user packages, list taxonomies, dismiss promotional offers, and review notices, and preview forms.

References

Share

1 affected software package

Software Type Plugin
Software Slug wp-user-frontend (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.6.9, or a newer patched version
Affected Version
  • <= 3.6.8
Patched Version
  • 3.6.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation