WP User Manager <= 2.6.2 - Arbitrary User Password Reset

7.5
Authorization Bypass Through User-Controlled Key
CVE CVE-2021-24655
CVSS 7.5 (High)
Publicly Published September 22, 2021
Last Updated January 22, 2024
Researcher AyeCode Ltd

Description

The WP User Manager WordPress plugin before 2.6.3 does not ensure that the user ID to reset the password of is related to the reset key given. As a result, any authenticated user can reset the password (to an arbitrary value) of any user knowing only their ID, and gain access to their account.

Wordfence blocked 10 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for WP User Manager – User Profile Builder & Membership

Software Type Plugin
Software Slug wp-user-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.3, or a newer patched version
Affected Version
  • <= 2.6.2
Patched Version
  • 2.6.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation