WP User Switch <= 1.0.2 - Authenticated (Subscriber+) Authentication Bypass via Cookie

Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2023-2546
CVSS 8.8 (High)
Publicly Published June 4, 2023
Last Updated June 13, 2023
Researcher Lana Codes - Wordfence


The WP User Switch plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 1.0.2. This is due to incorrect authentication checking in the 'wpus_allow_user_to_admin_bar_menu' function with the 'wpus_who_switch' cookie value. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to log in as any existing user on the site, such as an administrator, if they have access to the username.



1 affected software package

Software Type Plugin
Software Slug wp-user-switch (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.3, or a newer patched version
Affected Version
  • <= 1.0.2
Patched Version
  • 1.0.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.