WP-UserOnline <= 2.88.0 - Authenticated (Admin+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-2941
CVSS 5.5 (Medium)
Publicly Published August 22, 2022
Last Updated October 20, 2023
Researcher Juampa Rodríguez


The WP-UserOnline plugin for WordPress has multiple Stored Cross-Site Scripting vulnerabilities in versions up to, and including 2.88.0. This is due to the fact that all fields in the "Naming Conventions" section do not properly sanitize user input, nor escape it on output. This makes it possible for authenticated attackers, with administrative privileges, to inject JavaScript code into the setting that will execute whenever a user accesses the injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.



Vulnerability Details for WP-UserOnline

Software Type Plugin
Software Slug wp-useronline (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.88.1, or a newer patched version
Affected Version
  • <= 2.88.0
Patched Version
  • 2.88.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.