Viper GuestBook <= 1.3.15 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2015-9356
CVSS 6.1 (Medium)
Publicly Published April 20, 2015
Last Updated January 22, 2024
Researcher DANIEL CID - Sucuri


The Viper GuestBook plugin for WordPress is vulnerable to Cross-Site Scripting in versions up to, and including, 1.3.15 due to insufficient input sanitization and output escaping on a query arg. This makes it possible for attackers to inject arbitrary web scripts that execute in a victim's browser.



Vulnerability Details for WP-ViperGB

Software Type Plugin
Software Slug wp-vipergb (view on
Patched? Yes
Remediation Update to version 1.3.16, or a newer patched version
Affected Version
  • < 1.3.16
Patched Version
  • 1.3.16

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.