Whydonate – FREE Donate button <= 3.12.14 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-29238
CVSS 4.3 (Medium)
Publicly Published May 10, 2023
Last Updated January 22, 2024
Researcher easyBug

Description

The Whydonate – FREE Donate button plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.12.14. This is due to missing nonce validation on several functions. This makes it possible for unauthenticated attackers to modify the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Whydonate – FREE Donate button – Crowdfunding – Fundraising

Software Type Plugin
Software Slug wp-whydonate (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.12.16, or a newer patched version
Affected Version
  • <= 3.12.14
Patched Version
  • 3.12.16

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation