Worthy – VG WORT Integration für WordPress <= 1.6.5-6497609 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-24417
CVSS 5.4 (Medium)
Publicly Published May 30, 2023
Last Updated September 5, 2023
Researcher yuyudhn


The Worthy – VG WORT Integration für WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.6.5-6497609. This is due to missing nonce validation on various functions called via admin_post hooks. This makes it possible for unauthenticated attackers to control many of the plugins settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug wp-worthy (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.7.0-0cde1c2, or a newer patched version
Affected Version
  • * - 1.6.5-6497609 - * - 1.6.5-6497609
Patched Version
  • 1.7.0-0cde1c2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.