wpDiscuz <= 7.6.10 - Insufficient Authorization to Comment Submission on Deleted Posts

Missing Authorization
CVE CVE-2023-46309
CVSS 5.3 (Medium)
Publicly Published October 20, 2023
Last Updated November 13, 2023
Researcher Revan Arifio


The Comments – wpDiscuz plugin for WordPress is vulnerable to unauthorized modification of data due to insufficient validation on the comment functionality in all versions up to, and including, 7.6.10. This makes it possible for unauthenticated attackers to leave comments on trashed posts.



1 affected software package

Software Type Plugin
Software Slug wpdiscuz (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.6.11, or a newer patched version
Affected Version
  • <= 7.6.10
Patched Version
  • 7.6.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.