wpDiscuz <= 7.6.3 - Insecure Direct Object Reference to Comment Rating Increase/Decrease

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-3869
CVSS 5.3 (Medium)
Publicly Published September 12, 2023
Last Updated October 20, 2023
Researcher Vladislav Pokrovsky (ΞX.MI) - Independent AppSec Researcher


The wpDiscuz plugin for WordPress is vulnerable to unauthorized modification of data due to a missing authorization check on the voteOnComment function in versions up to, and including, 7.6.3. This makes it possible for unauthenticated attackers to increase or decrease the rating of a comment.



1 affected software package

Software Type Plugin
Software Slug wpdiscuz (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.6.4, or a newer patched version
Affected Version
  • <= 7.6.3
Patched Version
  • 7.6.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.