wpDiscuz <= 7.6.5 - Unauthenticated SQL Injection

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVSS 8.8 (High)
Publicly Published September 18, 2023
Last Updated September 18, 2023


The wpDiscuz plugin for WordPress is vulnerable to SQL Injection via the 'visibleCommentIds' parameter in versions up to, and including, 7.6.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This requires the 'Live Update' functionality to be enabled for subscriber+ exploitation, and the 'Enable Live Update for Guests' setting enabled for unauthenticated exploitation.



1 affected software package

Software Type Plugin
Software Slug wpdiscuz (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.6.6, or a newer patched version
Affected Version
  • < 7.6.6
Patched Version
  • 7.6.6

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.