Premium Packages - Sell Digital Products Securely <= 5.7.4 - Arbitrary User Meta Update to Authenticated (Subscriber+) Privilege Escalation

Improper Privilege Management
CVE CVE-2023-4293
CVSS 8.8 (High)
Publicly Published August 11, 2023
Last Updated August 12, 2023
Researcher István Márton - Wordfence


The Premium Packages - Sell Digital Products Securely plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 5.7.4 due to insufficient restriction on the 'wpdmpp_update_profile' function. This makes it possible for authenticated attackers, with minimal permissions such as a subscriber, to modify their user role by supplying the 'profile[role]' parameter during a profile update.



Vulnerability Details for Premium Packages – Sell Digital Products Securely

Software Type Plugin
Software Slug wpdm-premium-packages (view on
Patched? Yes
Remediation Update to version 5.7.5, or a newer patched version
Affected Version
  • <= 5.7.4
Patched Version
  • 5.7.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.