WPFunnels <= 2.7.15 - Insecure Direct Object Reference

Authorization Bypass Through User-Controlled Key
CVSS 5.4 (Medium)
Publicly Published July 10, 2023
Last Updated July 13, 2023


The WPFunnels plugin for WordPress is vulnerable to insecure direct object reference in versions up to, and including, 2.7.15. This is due to insufficient validation on a user controlled key. This makes it possible for authenticated attackers to perform actions on objects they aren't intended to manipulate.



1 affected software package

Software Type Plugin
Software Slug wpfunnels (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.7.16, or a newer patched version
Affected Version
  • < 2.7.16
Patched Version
  • 2.7.16

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.