WPSchoolPress <= 2.2.4 - Cross-Site Request Forgery

6.3
Cross-Site Request Forgery (CSRF)
CVSS 6.3 (Medium)
Publicly Published September 18, 2023
Last Updated January 22, 2024

Description

The WPSchoolPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.2.4. This is due to missing nonce validation on several functions called via AJAX actions in the /lib/wpsp-ajaxworks.php file. This makes it possible for unauthenticated attackers to perform a multitude of actions on behalf of other students or teachers, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug wpschoolpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.5, or a newer patched version
Affected Version
  • < 2.2.5
Patched Version
  • 2.2.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation