WpStream – Live Streaming, Video on Demand, Pay Per View <= 4.5.4 - Cross-Site Request Forgery via wpstream_update_local_event_settings

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-38512
CVSS 4.3 (Medium)
Publicly Published July 20, 2023
Last Updated July 26, 2023
Researcher Elliot

Description

The WpStream – Live Streaming, Video on Demand, Pay Per View plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.5.4. This is due to missing or incorrect nonce validation on the wpstream_update_local_event_settings function. This makes it possible for unauthenticated attackers to invoke this function and update local event settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug wpstream (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.5.5, or a newer patched version
Affected Version
  • <= 4.5.4
Patched Version
  • 4.5.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation