WPvivid Backup for MainWP <= 0.9.32 - Reflected Cross-Site Scripting

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-1383
CVSS 6.1 (Medium)
Publicly Published February 28, 2024
Last Updated March 13, 2024
Researcher Krzysztof Zając - CERT PL

Description

The WPvivid Backup for MainWP plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'id' parameter in all versions up to, and including, 0.9.32 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Share

Vulnerability Details for WPvivid Backup for MainWP

Software Type Plugin
Software Slug wpvivid-backup-mainwp (view on wordpress.org)
Patched? Yes
Remediation Update to version 0.9.33, or a newer patched version
Affected Version
  • <= 0.9.32
Patched Version
  • 0.9.33

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation