YARPP <= 5.30.4 - Authenticated (Subscriber+) Local File Inclusion

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')
CVE CVE-2022-45374
CVSS 8.8 (High)
Publicly Published April 18, 2023
Last Updated July 19, 2023
Researcher Rafie Muhammad - Patchstack


The YARPP plugin for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 5.30.4 via the yarpp shortcode due to insufficient validation on the 'template' user attribute. This allows subscriber-level attackers, and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.



1 affected software package

Software Type Plugin
Software Slug yet-another-related-posts-plugin (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.30.5, or a newer patched version
Affected Version
  • <= 5.30.4
Patched Version
  • 5.30.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.