Easy Forms for Mailchimp 3.0 - 5.0.6 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2014-7152
CVSS 7.2 (High)
Publicly Published September 26, 2014
Last Updated August 8, 2022
Researcher James Hooker


Cross-site scripting (XSS) vulnerability in the Easy MailChimp Forms plugin 3.0 through 5.0.6 for WordPress allows remote attackers to inject arbitrary web script or HTML via the update_options action to wp-admin/admin-ajax.php.



Vulnerability Details for Easy Forms for Mailchimp

Software Type Plugin
Software Slug yikes-inc-easy-mailchimp-extender (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.0.7, or a newer patched version
Affected Version
  • 3.0 - 5.0.6
Patched Version
  • 5.0.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.