YITH WooCommerce Compare <= 2.0.9 - Unauthenticated PHP Object Injection

Deserialization of Untrusted Data
CVSS 8.8 (High)
Publicly Published November 8, 2016
Last Updated January 22, 2024
Researcher Yorick Koster, - sumofpwn


The YITH WooCommerce Compare plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.0.9 via deserialization of untrusted input from the 'yith_woocompare_list' cookie. This allows unauthenticated attackers to inject a PHP Object. It has been confirmed that this vulnerability allows attackers to execute arbitrary PHP code.



Vulnerability Details for YITH WooCommerce Compare

Software Type Plugin
Software Slug yith-woocommerce-compare (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.0, or a newer patched version
Affected Version
  • <= 2.0.9
Patched Version
  • 2.1.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.