Yith WooCommerce Gift Cards Premium <= 3.19.0 - Unauthenticated Arbitrary File Upload

9.8
Unrestricted Upload of File with Dangerous Type
CVE CVE-2022-45359
CVSS 9.8 (Critical)
Publicly Published November 22, 2022
Last Updated January 30, 2023
Researcher Dave Jong - Patchstack

Description

The Yith WooCommerce Gift Cards Premium plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation and capability checks in the import_actions_from_settings_panel function in versions up to, and including, 3.19.0. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible. This is being actively exploited.

References

Share

1 affected software package

Software Type Plugin
Software Slug yith-woocommerce-gift-cards-premium (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.20.0, or a newer patched version
Affected Version
  • <= 3.19.0
Patched Version
  • 3.20.0

All the threat data shared in this database is powered by Wordfence Intelligence.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence Community Edition WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation