YITH WooCommerce Gift Cards Premium <= 3.23.1 - Missing Authorization

Missing Authorization
CVE CVE-2022-44633
CVSS 6.5 (Medium)
Publicly Published May 10, 2023
Last Updated May 15, 2023
Researcher Dave Jong - Patchstack


The YITH WooCommerce Gift Cards Premium plugin for WordPress is vulnerable to unauthorized gift card creation due to a missing capability check on one of its functions in versions up to, and including, 3.23.1. This makes it possible for unauthenticated attackers to create gift cards. Sanitization of user input is also insufficient, which allows users to inject malicious scripts.



1 affected software package

Software Type Plugin
Software Slug yith-woocommerce-gift-cards-premium (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.24.0, or a newer patched version
Affected Version
  • <= 3.23.1
Patched Version
  • 3.24.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.