YITH WooCommerce Gift Cards <= 4.12.0 - Missing Authorization to Unauthenticated WooCommerce Settings Update

Improper Authorization
CVE CVE-2024-0870
CVSS 5.3 (Medium)
Publicly Published May 13, 2024
Last Updated May 14, 2024
Researcher Francesco Carlucci


The YITH WooCommerce Gift Cards plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'save_mail_status' and 'save_email_settings' functions in all versions up to, and including, 4.12.0. This makes it possible for unauthenticated attackers to modify WooCommerce settings.



Vulnerability Details for YITH WooCommerce Gift Cards

Software Type Plugin
Software Slug yith-woocommerce-gift-cards (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.13.0, or a newer patched version
Affected Version
  • <= 4.12.0
Patched Version
  • 4.13.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.