YITH WooCommerce Product Add-Ons <= 4.2.0 - Missing Authorization

Missing Authorization
CVE CVE-2023-46635
CVSS 5.3 (Medium)
Publicly Published October 25, 2023
Last Updated October 30, 2023
Researcher Elliot


The YITH WooCommerce Product Add-Ons plugin for WordPress is vulnerable to unauthorized functionality due to a missing capability check on two of its AJAX actions in versions up to, and including, 4.2.0. This makes it possible for unauthenticated attackers to make use of this functionality and allows them to enable and disable blocks and addons.



1 affected software package

Software Type Plugin
Software Slug yith-woocommerce-product-add-ons (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.2.1, or a newer patched version
Affected Version
  • <= 4.2.0
Patched Version
  • 4.2.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.