YOP Poll <= 6.3.4 - Author+ Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-0205
CVSS 6.4 (Medium)
Publicly Published February 14, 2022
Last Updated January 4, 2023
Researcher Yoru Oni


The YOP Poll WordPress plugin before 6.3.5 does not sanitise and escape some of the settings (available to users with a role as low as author) before outputting them, leading to a Stored Cross-Site Scripting issue



Vulnerability Details for YOP Poll

Software Type Plugin
Software Slug yop-poll (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.3.5, or a newer patched version
Affected Version
  • <= 6.3.4
Patched Version
  • 6.3.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.