YOP Poll <= 6.5.26 - Race Condition to Vote Manipulation

Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')
CVE CVE-2023-6109
CVSS 5.3 (Medium)
Publicly Published November 13, 2023
Last Updated January 22, 2024
Researcher RIN MIYACHI


The YOP Poll plugin for WordPress is vulnerable to a race condition in all versions up to, and including, 6.5.26. This is due to improper restrictions on the add() function. This makes it possible for unauthenticated attackers to place multiple votes on a single poll even when the poll is set to one vote per person.



1 affected software package

Software Type Plugin
Software Slug yop-poll (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.5.27, or a newer patched version
Affected Version
  • <= 6.5.26
Patched Version
  • 6.5.27

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.