Video Player for YouTube <= 1.3 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24414
CVSS 5.4 (Medium)
Publicly Published September 22, 2021
Last Updated January 22, 2024
Researcher Michal Lipinski


The Video Player for YouTube WordPress plugin before 1.4 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode



Vulnerability Details for Video Player for YouTube

Software Type Plugin
Software Slug yt-player (view on
Patched? Yes
Remediation Update to version 1.4, or a newer patched version
Affected Version
  • < 1.4
Patched Version
  • 1.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.