Betheme <= 27.1.1 - Missing Authorization via '_tool_history_delete'

Missing Authorization
CVE CVE-2023-39998
CVSS 6.5 (Medium)
Publicly Published August 10, 2023
Last Updated August 15, 2023
Researcher Rafie Muhammad - Patchstack


The Betheme theme for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the '_tool_history_delete' AJAX function in versions up to, and including, 27.1.1. This makes it possible for authenticated attackers, with author-level access and above, to delete site design revisions and backups.



1 affected software package

Software Type Theme
Software Slug betheme
Patched? Yes
Remediation Update to version 27.1.2, or a newer patched version
Affected Version
  • <= 27.1.1
Patched Version
  • 27.1.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.