Big Store <= 1.9.3 - Cross-Site Request Forgery to Arbitrary Plugin Activation

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-27431
CVSS 4.3 (Medium)
Publicly Published March 5, 2023
Last Updated March 8, 2023
Researcher Dave Jong - Patchstack


The Big Store plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.9.3. This is due to missing or incorrect nonce validation on the default_home and th_activeplugin functions. This makes it possible for unauthenticated attackers to activate arbitrary plugins via a forged request, granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Theme
Software Slug big-store (view on
Patched? Yes
Remediation Update to version 1.9.4, or a newer patched version
Affected Version
  • <= 1.9.3
Patched Version
  • 1.9.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.