Multiple sparklewpthemes Themes (Various versions) - Missing Authorization to Arbitrary Plugin Activation

5.3
Missing Authorization
CVE CVE-2023-32959
CVSS 5.3 (Medium)
Publicly Published May 16, 2023
Last Updated March 25, 2024
Researcher Dave Jong - Patchstack

Description

Several themes for WordPress are vulnerable to unauthorized modification of data due to a missing capability check on the activate_plugin() function called via an AJAX action in various versions. This makes it possible for authenticated attackers, with subscriber-level access and above, to activate arbitrary plugins.

References

Share

Vulnerability Details for Craft Blog

Software Type Theme
Software Slug craft-blog (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.0.7

10 other affected software packages

Software Type Theme
Software Slug appzend (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.2.1
Software Type Theme
Software Slug buzzstore (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.3.6
Software Type Theme
Software Slug fitness-park (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.0.6
Software Type Theme
Software Slug kathmag (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.0.6
Software Type Theme
Software Slug kingcabs (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.9, or a newer patched version
Affected Version
  • <= 1.1.8
Patched Version
  • 1.1.9
Software Type Theme
Software Slug medical-heed (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.1.4
Software Type Theme
Software Slug metrostore (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.3.2
Software Type Theme
Software Slug online-estore (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.0.9
Software Type Theme
Software Slug sparklestore (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.6.3, or a newer patched version
Affected Version
  • <= 1.6.2
Patched Version
  • 1.6.3
Software Type Theme
Software Slug spidermag (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • <= 1.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation