Editorialmag <= 1.2.0 - Missing Authorization to Authenticated Plugin Activation

Missing Authorization
CVE CVE-2023-32129
CVSS 6.3 (Medium)
Publicly Published May 4, 2023
Last Updated March 25, 2024
Researcher Dave Jong - Patchstack


The Editorialmag theme for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the activate_plugin function in versions up to, and including, 1.2.0. This makes it possible for authenticated attackers with subscriber-level permissions or above to activate arbitrary plugins on the site.



Vulnerability Details for Editorialmag

Software Type Theme
Software Slug editorialmag (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.1, or a newer patched version
Affected Version
  • <= 1.2.0
Patched Version
  • 1.2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.