Educenter <= 1.5.7 - Missing Authorization via activate_plugin

Missing Authorization
CVE CVE-2023-30480
CVSS 4.3 (Medium)
Publicly Published April 14, 2023
Last Updated March 25, 2024
Researcher Dave Jong - Patchstack


The Educenter theme for WordPress is vulnerable to unauthorized plugin activation due to a missing capability check on the activate_plugin function called via and AJAX action in versions up to, and including, 1.5.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to activate arbitrary plugins.



Vulnerability Details for Educenter

Software Type Theme
Software Slug educenter (view on
Patched? Yes
Remediation Update to version 1.5.8, or a newer patched version
Affected Version
  • <= 1.5.7
Patched Version
  • 1.5.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.