EmpowerWP <= 1.0.21 - Cross-Site Request Forgery to Notice Dismissal

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-34809
CVSS 4.3 (Medium)
Publicly Published May 13, 2024
Last Updated May 19, 2024
Researcher Dhabaleshwar Das


The EmpowerWP theme for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.0.21. This is due to missing or incorrect nonce validation on the empower_admin_ajax_welcome_notice_dismiss function. This makes it possible for unauthenticated attackers to dismiss a notice via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for EmpowerWP

Software Type Theme
Software Slug empowerwp (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.22, or a newer patched version
Affected Version
  • <= 1.0.21
Patched Version
  • 1.0.22

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.