Houzez <= 2.7.1 - Privilege Escalation

Incorrect Privilege Assignment
CVE CVE-2023-26540
CVSS 9.8 (Critical)
Publicly Published February 27, 2023
Last Updated February 28, 2023
Researcher Dave Jong - Patchstack


The Houzez theme for WordPress is vulnerable to privilege escalation in versions up to, and including, 2.7.1. This is due to improper assignment of privileges on user management/registration that allows users to supply their own role via the houzez_change_user_role and houzez_register_user_with_membership AJAX actions. This makes it possible for unauthenticated attackers to register as administrators on vulnerable sites.



1 affected software package

Software Type Theme
Software Slug houzez
Patched? Yes
Remediation Update to version 2.7.2, or a newer patched version
Affected Version
  • <= 2.7.1
Patched Version
  • 2.7.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.