QAEngine <= 1.4 - Privilege Escalation

Improper Privilege Management
CVSS 8.8 (High)
Publicly Published April 24, 2015
Last Updated January 22, 2024
Researcher Evex - Evex


The QAEngine theme for WordPress is vulnerable to Privilege Escalation in versions up to, and including, 1.4 via the 'class-ae-users.php' file and 'ae-sync-user' AJAX action. This makes it possible for authenticated attackers to gain access to an administrative account.



1 affected software package

Software Type Theme
Software Slug qaengine
Patched? Yes
Remediation Update to version 1.5, or a newer patched version
Affected Version
  • <= 1.4
Patched Version
  • 1.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.