Responsive <= 5.0.2 - Missing Authorization to HTML Injection

7.5
Missing Authorization
CVE CVE-2024-2848
CVSS 7.5 (High)
Publicly Published March 28, 2024
Last Updated April 29, 2024
Researchers Krzysztof Zając - CERT PL
Muhammad Zeeshan (Xib3rR4dAr)

Description

The Responsive theme for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_footer_text_callback function in all versions up to, and including, 5.0.2. This makes it possible for unauthenticated attackers to inject arbitrary HTML content into the site's footer.

Wordfence blocked 22,934 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Responsive

Software Type Theme
Software Slug responsive (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.0.3, or a newer patched version
Affected Version
  • <= 5.0.2
Patched Version
  • 5.0.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation