Royal Elementor Kit <= 1.0.116 - Missing Authorization to Arbitrary Transient Update

Missing Authorization
CVE CVE-2024-0835
CVSS 4.3 (Medium)
Publicly Published February 5, 2024
Last Updated February 5, 2024
Researcher Sean Murphy


The Royal Elementor Kit theme for WordPress is vulnerable to unauthorized arbitrary transient update due to a missing capability check on the dismissed_handler function in all versions up to, and including, 1.0.116. This makes it possible for authenticated attackers, with subscriber access or higher, to update arbitrary transients. Note, that these transients can only be updated to true and not arbitrary values.



Vulnerability Details for Royal Elementor Kit

Software Type Theme
Software Slug royal-elementor-kit (view on
Patched? Yes
Remediation Update to version 1.0.117, or a newer patched version
Affected Version
  • <= 1.0.116
Patched Version
  • 1.0.117

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.