Tainacan Interface <= 2.7.2 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-3867
CVSS 6.1 (Medium)
Publicly Published April 15, 2024
Last Updated April 16, 2024
Researcher Matheus Nascimento de Camargo


The archive-tainacan-collection theme for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in version 2.7.2. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.



Vulnerability Details for Tainacan Interface

Software Type Theme
Software Slug tainacan-interface (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.7.3, or a newer patched version
Affected Version
  • <= 2.7.2
Patched Version
  • 2.7.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.