uDesign Theme 2.3.0 - 2.7.9 - Unauthenticated DOM Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2015-7357
CVSS 6.1 (Medium)
Publicly Published October 5, 2015
Last Updated February 3, 2023
Researcher Kenan G.


Cross-site scripting (XSS) vulnerability in the uDesign (aka U-Design) theme 2.3.0 before 2.7.10 for WordPress allows remote attackers to inject arbitrary web script or HTML via a fragment identifier, as demonstrated by #<svg onload=alert(1)>.



Vulnerability Details for uDesign - Responsive WordPress Theme

Software Type Theme
Software Slug u-design (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.7.10, or a newer patched version
Affected Version
  • 2.3.0 - 2.7.9
Patched Version
  • 2.7.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.