360 Javascript Viewer <= 1.7.12 - Missing Authorization to Plugin Settings Update

Missing Authorization
CVE CVE-2024-1637
CVSS 4.3 (Medium)
Publicly Published March 21, 2024
Last Updated April 9, 2024
Researcher Lucio Sá


The 360 Javascript Viewer plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check and nonce exposure on several AJAX actions in all versions up to, and including, 1.7.12. This makes it possible for authenticated attackers, with subscriber access or higher, to update plugin settings.



Vulnerability Details for 360 Javascript Viewer

Software Type Plugin
Software Slug 360deg-javascript-viewer (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.7.13, or a newer patched version
Affected Version
  • <= 1.7.12
Patched Version
  • 1.7.13

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.